package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<timestamp>\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}\.\d{3}Z) (?<level>\w+) (?<servicename>(\w+|\-))\[(?<uniquething>[A-F\d]+)\] \[(?<function>Originator@\d+) sub=(?<subsys>\S+)\] (?<body>.*)$`)
var str = `2017-05-04T14:46:44.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=Default] Logging uses fast path: false
2017-05-04T14:46:45.163Z Section for PyVsanMOPropProvider, pid=68004, version=0.1, build=5310541, option=Release
2017-05-04T14:46:46Z mark: storage-path-claim-completed
2017-05-04T14:46:47.163Z verbose vsansystem[7AFFC9DB20] [Originator@6876 sub=Default] Dumping early logs:
------ Early init logs start --------
2017-05-04T14:46:47.163Z info -[7AFFC9DB20] [Originator@6876 sub=Default] Glibc malloc guards disabled.
2017-05-04T14:46:47.163Z info -[7AFFC9DB20] [Originator@6876 sub=Default] Initialized SystemFactory
------ Early init logs end --------
2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=Default] Logging uses fast path: false
2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=Default] The bora/lib logs WILL be handled by VmaCore
2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=Default] Initialized channel manager
2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=Default] Current working directory: /var/log/vmware
2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=ThreadPool] Catch work item exceptions disabled.
2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=FairScheduler] Priority level 4 is now active.
2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=WorkQueue.vmacoreDefaultIOCompletionQueue] Created: WorkQueue.vmacoreDefaultIOCompletionQueue, type = fair, priority = 4 , itemWeight = 1
2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=FairScheduler] Priority level 8 is now active.
2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=WorkQueue.vmacoreDefaultIOQueue] Created: WorkQueue.vmacoreDefaultIOQueue, type = fair, priority = 8 , itemWeight = 1
2017-05-04T14:46:47.163Z info vsansystem[7AFFC9DB20] [Originator@6876 sub=FairScheduler] Priority level 16 is now active.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}