import re
regex = re.compile(r"user_b: (.*?)^[0-9]", flags=re.MULTILINE | re.DOTALL)
test_str = ("27/07/18, 12:02 PM - user_a: https://www.youtube.com/\n"
" Watch this\n"
"27/07/18, 12:15 PM - user_b: <Media omitted>\n"
"27/07/18, 12:52 PM - user_b: Read this fully\n"
"some text\n"
"some text\n"
".\n"
"some text\n"
"27/07/18, 12:56 PM - user_c: text ..")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")