re = /user_b: (.*?)^[0-9]/m
str = '27/07/18, 12:02 PM - user_a: https://www.youtube.com/
Watch this
27/07/18, 12:15 PM - user_b: <Media omitted>
27/07/18, 12:52 PM - user_b: Read this fully
some text
some text
.
some text
27/07/18, 12:56 PM - user_c: text ..'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end