using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\D*|\d{1,4})*\K\b\d{5}(?!\d)";
string input = @"aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}