re = /^(?:\D*|\d{1,4})*\K\b\d{5}(?!\d)/m
str = 'aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end