import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\d*[1-9]\\d*)[0](\\d*[1-9]\\d*)|(\\d*[2-9]\\d*)[1](\\d*[2-9]\\d*)|(\\d*[3-9]\\d*)[2](\\d*[3-9]\\d*)|(\\d*[4-9]\\d*)[3](\\d*[4-9]\\d*)|(\\d*[5-9]\\d*)[4](\\d*[5-9]\\d*)|(\\d*[6-9]\\d*)[5](\\d*[6-9]\\d*)|(\\d*[7-9]\\d*)[6](\\d*[7-9]\\d*)|(\\d*[8-9]\\d*)[7](\\d*[8-9]\\d*)|(\\d*[9]\\d*)[8](\\d*[9]\\d*))|((\\d*[0-8]\\d*)[9](\\d*[0-8]\\d*)|(\\d*[0-7]\\d*)[8](\\d*[0-7]\\d*)|(\\d*[0-6]\\d*)[7](\\d*[0-6]\\d*)|(\\d*[0-5]\\d*)[6](\\d*[0-5]\\d*)|(\\d*[0-4]\\d*)[5](\\d*[0-4]\\d*)|(\\d*[0-3]\\d*)[4](\\d*[0-3]\\d*)|(\\d*[0-2]\\d*)[3](\\d*[0-2]\\d*)|(\\d*[0-1]\\d*)[2](\\d*[0-1]\\d*)|(\\d*[0]\\d*)[1](\\d*[0]\\d*))";
final String string = "123\n"
+ "234567\n"
+ "0123456789\n"
+ "87654\n"
+ "321\n"
+ "985\n"
+ "346\n"
+ "320\n\n"
+ "12342\n"
+ "7655338\n"
+ "9876789\n"
+ "2000000001";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}