const regex = /((\d*[1-9]\d*)[0](\d*[1-9]\d*)|(\d*[2-9]\d*)[1](\d*[2-9]\d*)|(\d*[3-9]\d*)[2](\d*[3-9]\d*)|(\d*[4-9]\d*)[3](\d*[4-9]\d*)|(\d*[5-9]\d*)[4](\d*[5-9]\d*)|(\d*[6-9]\d*)[5](\d*[6-9]\d*)|(\d*[7-9]\d*)[6](\d*[7-9]\d*)|(\d*[8-9]\d*)[7](\d*[8-9]\d*)|(\d*[9]\d*)[8](\d*[9]\d*))|((\d*[0-8]\d*)[9](\d*[0-8]\d*)|(\d*[0-7]\d*)[8](\d*[0-7]\d*)|(\d*[0-6]\d*)[7](\d*[0-6]\d*)|(\d*[0-5]\d*)[6](\d*[0-5]\d*)|(\d*[0-4]\d*)[5](\d*[0-4]\d*)|(\d*[0-3]\d*)[4](\d*[0-3]\d*)|(\d*[0-2]\d*)[3](\d*[0-2]\d*)|(\d*[0-1]\d*)[2](\d*[0-1]\d*)|(\d*[0]\d*)[1](\d*[0]\d*))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d*[1-9]\\d*)[0](\\d*[1-9]\\d*)|(\\d*[2-9]\\d*)[1](\\d*[2-9]\\d*)|(\\d*[3-9]\\d*)[2](\\d*[3-9]\\d*)|(\\d*[4-9]\\d*)[3](\\d*[4-9]\\d*)|(\\d*[5-9]\\d*)[4](\\d*[5-9]\\d*)|(\\d*[6-9]\\d*)[5](\\d*[6-9]\\d*)|(\\d*[7-9]\\d*)[6](\\d*[7-9]\\d*)|(\\d*[8-9]\\d*)[7](\\d*[8-9]\\d*)|(\\d*[9]\\d*)[8](\\d*[9]\\d*))|((\\d*[0-8]\\d*)[9](\\d*[0-8]\\d*)|(\\d*[0-7]\\d*)[8](\\d*[0-7]\\d*)|(\\d*[0-6]\\d*)[7](\\d*[0-6]\\d*)|(\\d*[0-5]\\d*)[6](\\d*[0-5]\\d*)|(\\d*[0-4]\\d*)[5](\\d*[0-4]\\d*)|(\\d*[0-3]\\d*)[4](\\d*[0-3]\\d*)|(\\d*[0-2]\\d*)[3](\\d*[0-2]\\d*)|(\\d*[0-1]\\d*)[2](\\d*[0-1]\\d*)|(\\d*[0]\\d*)[1](\\d*[0]\\d*))', 'g')
const str = `123
234567
0123456789
87654
321
985
346
320
12342
7655338
9876789
2000000001`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}