using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div(?:(?!</div>).)*<div(?:(?!</div>).)*{{ upc }}.*?</div>\s*</div>";
string input = @"<div class=""form-group"">
<label class=""col-sm-2 control-label"" for=""input-sku""><span data-toggle=""tooltip"" title=""{{ help_sku }}"">{{ entry_sku }}</span></label>
<div class=""col-sm-10"">
<input type=""text"" name=""sku"" value=""{{ sku }}"" placeholder=""{{ entry_sku }}"" id=""input-sku"" class=""form-control""/>
</div>
</div>
<div class=""form-group"">
<label class=""col-sm-2 control-label"" for=""input-upc""><span data-toggle=""tooltip"" title=""{{ help_upc }}"">{{ entry_upc }}</span></label>
<div class=""col-sm-10"">
<input type=""text"" name=""upc"" value=""{{ upc }}"" placeholder=""{{ entry_upc }}"" id=""input-upc"" class=""form-control""/>
</div>
</div>
<div class=""form-group"">
<label class=""col-sm-2 control-label"" for=""input-ean""><span data-toggle=""tooltip"" title=""{{ help_ean }}"">{{ entry_ean }}</span></label>
<div class=""col-sm-10"">
<input type=""text"" name=""ean"" value=""{{ ean }}"" placeholder=""{{ entry_ean }}"" id=""input-ean"" class=""form-control""/>
</div>
</div>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}