import re
regex = re.compile(r"<div(?:(?!</div>).)*<div(?:(?!</div>).)*{{ upc }}.*?</div>\s*</div>", flags=re.DOTALL)
test_str = ("<div class=\"form-group\">\n"
" <label class=\"col-sm-2 control-label\" for=\"input-sku\"><span data-toggle=\"tooltip\" title=\"{{ help_sku }}\">{{ entry_sku }}</span></label>\n"
" <div class=\"col-sm-10\">\n"
" <input type=\"text\" name=\"sku\" value=\"{{ sku }}\" placeholder=\"{{ entry_sku }}\" id=\"input-sku\" class=\"form-control\"/>\n"
" </div>\n"
"</div>\n"
"<div class=\"form-group\">\n"
" <label class=\"col-sm-2 control-label\" for=\"input-upc\"><span data-toggle=\"tooltip\" title=\"{{ help_upc }}\">{{ entry_upc }}</span></label>\n"
" <div class=\"col-sm-10\">\n"
" <input type=\"text\" name=\"upc\" value=\"{{ upc }}\" placeholder=\"{{ entry_upc }}\" id=\"input-upc\" class=\"form-control\"/>\n"
" </div>\n"
"</div>\n"
"<div class=\"form-group\">\n"
" <label class=\"col-sm-2 control-label\" for=\"input-ean\"><span data-toggle=\"tooltip\" title=\"{{ help_ean }}\">{{ entry_ean }}</span></label>\n"
" <div class=\"col-sm-10\">\n"
" <input type=\"text\" name=\"ean\" value=\"{{ ean }}\" placeholder=\"{{ entry_ean }}\" id=\"input-ean\" class=\"form-control\"/>\n"
" </div>\n"
"</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")