using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(?:(?!keyword\b)\w+\h+){1,3}keyword\b(?=((?:\h+(?!keyword\b)\w+){1,3}))";
string input = @"word1 word2 word3 keyword word4 word5 word6 keyword word7 word8 word9 word10
word2 keyword word4 word5 word6 keyword word7 word8
word2 word3 keyword word4 word5 word6 keyword word7 keyword word10";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}