import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(?:(?!keyword\\b)\\w+\\h+){1,3}keyword\\b(?=((?:\\h+(?!keyword\\b)\\w+){1,3}))";
final String string = "word1 word2 word3 keyword word4 word5 word6 keyword word7 word8 word9 word10\n"
+ "word2 keyword word4 word5 word6 keyword word7 word8\n"
+ "word2 word3 keyword word4 word5 word6 keyword word7 keyword word10";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}