package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+$`)
var str = `rb_done_1
rb_${4}done`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}