$re = '/^\w+$/m';
$str = 'rb_done_1
rb_${4}done';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);