use strict;
my $str = 'Q: diff between null and undefined?
A: Null indicates an intentional empty value.
- Undefined indicates the total absence of a value. This happen when only the variable was declared without any initializer. A missing key in an object is also undefined.
```javascript
export function ticketStatus(tickets, ticketId) {
if (tickets[ticketId] === undefined) {
return \'unknown ticket id\';
} else if (tickets[ticketId] === null) {
return \'not sold\';
} else {
return `sold to ${tickets[ticketId]}`;
}
}
```
<!--ID: 1673953179724-->
---
Q: rewrite to use [[JS Object.assign]]
```javascript
visitor.ticketId = null;
return visitor;
```
A: Just pass only the props we want to overwrite to assign
```javascript
return Object.assign(visitor, {ticketId: null});
```
<!--ID: 1673953179746-->
---
Q: diff between isNaN() global vs Number.isNaN()?
A: global isNaN() does type conversion.
- Since I am trying to test whether the string contains a valid number, this is the right choice.
- If the input is already a number, then Number.isNaN() might be better. as
---
';
my $regex = qr/^Q: ((?:.*|\n)*?)\n*A: (.+(?:\n(?:^.{1,3}$|^.{4}(?<!<!--).*))*)
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}