# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"^Q: ((?:.*|\n)*?)\n*A: (.+(?:\n(?:^.{1,3}$|^.{4}(?<!<!--).*))*)\n")
test_str = ("Q: diff between null and undefined?\n\n"
"A: Null indicates an intentional empty value. \n"
"- Undefined indicates the total absence of a value. This happen when only the variable was declared without any initializer. A missing key in an object is also undefined. \n"
"```javascript\n"
"export function ticketStatus(tickets, ticketId) {\n"
" if (tickets[ticketId] === undefined) {\n"
" return 'unknown ticket id';\n"
" } else if (tickets[ticketId] === null) {\n"
" return 'not sold';\n"
" } else {\n\n"
" return `sold to ${tickets[ticketId]}`;\n"
" }\n"
"}\n"
"```\n"
"<!--ID: 1673953179724-->\n\n\n"
"---\n"
"Q: rewrite to use [[JS Object.assign]]\n"
"```javascript\n"
"visitor.ticketId = null;\n\n"
"return visitor;\n"
"```\n\n\n"
"A: Just pass only the props we want to overwrite to assign\n"
"```javascript\n"
"return Object.assign(visitor, {ticketId: null});\n"
"```\n"
"<!--ID: 1673953179746-->\n\n\n"
"---\n\n"
"Q: diff between isNaN() global vs Number.isNaN()?\n\n"
"A: global isNaN() does type conversion. \n"
"- Since I am trying to test whether the string contains a valid number, this is the right choice. \n"
"- If the input is already a number, then Number.isNaN() might be better. as\n\n"
"---\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.