package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):[^,]*,`)
var str = `open: boolean,
onDidDismiss: () => void,
message: string,
showAddReceiptModal: boolean,
showModal: (value: (((prevState: boolean) => boolean) | boolean)) => void,
vehicleTabRef: React.MutableRefObject<null>,
onReceiptSubmit: (data) => void,
vehicle: any,
showModal1: boolean,
showModal2: (value: (((prevState: boolean) => boolean) | boolean)) => void,
selectedReceipt: { __typename: "Receipt" | undefined; id: string | undefined; purchaseDate: string | undefined; sellerName: string | undefined; sellerAddress: string | undefined; sellerCity: string | undefined; sellerState: string | undefined; sellerZipCode: string | undefined; totalAmount: number | undefined; gallonsPurchased: number | undefined; image?: string | null | undefined | undefined; userID?: string | null | undefined | undefined; vehicleID: string | undefined; vehicle?: Vehicle | null | undefined | undefined; taxRefund?: number | null | undefined | undefined; createdAt: string | undefined; updatedAt: string | undefined },
onClick: () => void,
onClick1: () => void,
dataEditing: boolean,
toastMessage: (val) => void,
editing: (bool) => void,
showToast: (bool) => void,
showModal3: boolean,
showModal4: (bool) => void,
dateFilter: { startDate: string; endDate: string },`
var substitution = ","
fmt.Println(re.ReplaceAllString(str, substitution))
}