# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(\S+).*?<\/\1>(*SKIP)(*FAIL)| *\([^()]*\) */ /g;t' <<< "I want this to be (deleted) but not these: <a href=\"/wiki/Statement_(logic)\" title=\"Statement (logic)\">statements</a> and (this) should be removed.
(omit) <b>bold (bold)</b>
<s>strikethrough (s)</s> (omit)
"