use strict;
my $str = 'I want this to be (deleted) but not these: <a href="/wiki/Statement_(logic)" title="Statement (logic)">statements</a> and (this) should be removed.
(omit) <b>bold (bold)</b>
<s>strikethrough (s)</s> (omit)
';
my $regex = qr~<(\S+).*?</\1>(*SKIP)(*FAIL)| *\([^()]*\) *~p;
my $subst = ' ';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";