using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\[\] \[[^]]+\] ([A-Za-z0-9_]+) > (.+)$";
string input = @"[Zaza_TOP -> Мне] zaza";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}