$re = '/^\[\] \[[^]]+\] ([A-Za-z0-9_]+) > (.+)$/';
$str = '[Zaza_TOP -> Мне] zaza';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);