package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^)]*)\s*\(([^)]*)\)\s*\(?([^)^/]*)?\)?\s*\(?([^)^/]*)?\)?`)
var str = `Adventures of Tintin, The - The Game (USA) (En,Fr,Es,Pt)/
Adventures of Tintin, The - The Secret of the Unicorn (Europe) (En,Fr,De,Es,It,Nl,Sv,No,Da,Fi)/
Adventures of Tintin, The - The Game (USA) (Rev 1)/
Adventures of Tintin, The - The Secret of the Unicorn (Europe) (En,Fr,De,Es,It,Nl,Sv,No,Da,Fi)/ `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}