re = /^([^)]*)\s*\(([^)]*)\)\s*\(?([^)^\/]*)?\)?\s*\(?([^)^\/]*)?\)?/m
str = 'Adventures of Tintin, The - The Game (USA) (En,Fr,Es,Pt)/
Adventures of Tintin, The - The Secret of the Unicorn (Europe) (En,Fr,De,Es,It,Nl,Sv,No,Da,Fi)/
Adventures of Tintin, The - The Game (USA) (Rev 1)/
Adventures of Tintin, The - The Secret of the Unicorn (Europe) (En,Fr,De,Es,It,Nl,Sv,No,Da,Fi)/ '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end