using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\w+)@)?(\w+):(?:\/\w+){2}\/((?:\w|\.)*)";
string input = @"
test23@testbee:/var/bee/
or
testbee:/var/bee/test.html
I need to extract three string here: test23 (if it is available) , testbee and test.html
So, in Perl,
($user, $sys, $file) = ($source =~ /(\S*?)\@?(\S+?):?[^:]*?([^\/]+)$/);
for 1. this gives, $user = , $sys = test@testbee, $file = test.html for 2. this gives, $user = , $sys = test, $file = test.html
Is there a way, I can just use one expression to get the user 'test' if it exists and nothing if it doesnt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}