// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:(\w+)@)?(\w+):(?:\/\w+){2}\/((?:\w|\.)*)").unwrap();
let string = "
test23@testbee:/var/bee/
or
testbee:/var/bee/test.html
I need to extract three string here: test23 (if it is available) , testbee and test.html
So, in Perl,
($user, $sys, $file) = ($source =~ /(\\S*?)\\@?(\\S+?):?[^:]*?([^\\/]+)$/);
for 1. this gives, $user = , $sys = test@testbee, $file = test.html for 2. this gives, $user = , $sys = test, $file = test.html
Is there a way, I can just use one expression to get the user 'test' if it exists and nothing if it doesnt";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}