$re = '/\G(?:\W*(?:\bs(?:b|th)\.)?)*+\K./m';
$str = 'leave sb. alone
pick one\'s way forward
suffer from sth.';
$subst = "X";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;