import Foundation
let pattern = #"\G(?:\W*(?:\bs(?:b|th)\.)?)*+\K."#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
leave sb. alone
pick one's way forward
suffer from sth.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"X"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)