using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"IPA server version (\d+\.\d+\.\d+).*";
string input = @"IPA server version 4.11.0. API version 2.253
IPA server version 4.9.5. API version 2.253";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}