import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(public|)\\s+(?<type>[^\\s]+)\\s+(?<name>[^\\s]+)\\s*\\{(\\s*(get|set)\\s*;){2}\\s*\\}";
final String string = "public TypeName PropertyName { get; set; }";
final String subst = "public static readonly DependencyProperty ${name}Property = DependencyProperty.Register(\"${name}\", typeof(${type}), typeof(DependencyObjectType), new PropertyMetadata(default(${type}), ${name}Changed));\\nprivate static void ${name}Changed(DependencyObject dependencyObject, DependencyPropertyChangedEventArgs dependencyPropertyChangedEventArgs)\\n{\\nvar dependencyObjectType = dependencyObject as DependencyObjectType;\\nif(dependencyObjectType == null)\\nreturn;\\nvar oldValue = (${type})dependencyPropertyChangedEventArgs.OldValue;\\nvar newValue = (${type})dependencyPropertyChangedEventArgs.NewValue;\\n/* Logic... */\\n}\\n/// <summary>\\n/// ${name}\\n/// </summary>\\npublic ${type} ${name}\\n{\\nget { return (${type})GetValue(${name}Property); }\\nset { SetValue(${name}Property, value); }\\n}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}