#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(*COMMIT).*?(1.{0,5}2|23).*"
Local $sString = "1.....23" & @CRLF & _
"1.....21" & @CRLF & _
"23......" & @CRLF & _
"12.....1" & @CRLF & _
"1...2..." & @CRLF & _
"....23.." & @CRLF & _
"213....2" & @CRLF & _
"1......2" & @CRLF & _
"213....3" & @CRLF & _
"2.....21"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")