package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(*COMMIT).*?(1.{0,5}2|23).*`)
var str = `1.....23
1.....21
23......
12.....1
1...2...
....23..
213....2
1......2
213....3
2.....21`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}