package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^A-Za-z ]Z[A-Z0-9]+[^_ ]`)
var str = `SUZANO ZANO ZMES ZDIA ZANO_MES`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}