$re = '/[^A-Za-z ]Z[A-Z0-9]+[^_ ]/m';
$str = 'SUZANO ZANO ZMES ZDIA ZANO_MES';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);