$re = '/https://rextester.com/JFUKE76014/m';
$str = 'COINGBIT
Commit fb5aa46
to 0x9d9b6f05d7b72588f83cc60fda4286ba45d13924
Nonce 6324
Rash 0xa964e1ee4c92c25f47392f67b735095304631089b5f2173825b7e93f49f08d57
Bloco 3391586
valor=us$ 7.000.000.000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);