#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^/[^/\n]*"
Local $sString = "/" & @CRLF & _
"/sample-url" & @CRLF & _
"/sample-url-2/" & @CRLF & _
"/#sample-url-5/" & @CRLF & _
"/sample-url-3/sample-url-4" & @CRLF & _
"/sample-url-3/sample-url-6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")