package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^/[^/\n]*`)
var str = `/
/sample-url
/sample-url-2/
/#sample-url-5/
/sample-url-3/sample-url-4
/sample-url-3/sample-url-6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}