$re = '/DROP TABLE.*?`\K[^`]+/m';
$str = 'DROP TABLE `SOME TEXT` DROP TABLE `SOME TEXT2`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);