re = /DROP TABLE.*?`\K[^`]+/m
str = 'DROP TABLE `SOME TEXT` DROP TABLE `SOME TEXT2`'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end