package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\p{Han}+[\p{Han}\d\. \-。]*)`)
var str = `That would probably cost you about fifty bucks...
那大概要花掉你50美元左右 100-200。 and some english
and some more english on a new line.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}