import re
regex = re.compile(r"(\p{Han}+[\p{Han}\d\. \-。]*)")
test_str = ("That would probably cost you about fifty bucks...\n\n"
"那大概要花掉你50美元左右 100-200。 and some english\n"
"and some more english on a new line.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")