import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+([, ]+\\w+){1,2}";
final String string = "\n"
+ "Bauman, Steve\n"
+ "Steve Bauman\n"
+ "John, Doe\n"
+ "JD Sallinger\n"
+ "Bauman, Steve\n"
+ "Steve Bauman\n"
+ "Doe, Mary Sue\n"
+ "Mary Sue Doe\n"
+ "Juan Carlos Ferrero\n"
+ "Billy, Ray, Michael\n\n"
+ "// WILL_NOT_MATCH\n"
+ "John\n"
+ "Steve\n"
+ "Bauman\n"
+ "O'Rielly\n"
+ "Marc O'Connor\n"
+ "John_Doe\n"
+ "Steve-O\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}