$re = '/\w+([, ]+\w+){1,2}/';
$str = '
Bauman, Steve
Steve Bauman
John, Doe
JD Sallinger
Bauman, Steve
Steve Bauman
Doe, Mary Sue
Mary Sue Doe
Juan Carlos Ferrero
Billy, Ray, Michael
// WILL_NOT_MATCH
John
Steve
Bauman
O\'Rielly
Marc O\'Connor
John_Doe
Steve-O
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);