#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^crt|\G(?!\A))(?:(?!^$)\D)*\K[.:\d]+"
Local $sString = "crt - 00:00:00 up 200 days, 23:35, 0 users, load average: 0.04, 0.05, 0.02" & @CRLF & _
"Tasks: 300 total, 2 running, 298 sleeping, 0 stopped, 0 zombie" & @CRLF & _
"Cpu(s): 12.0%us, 2.5%sy, 0.0%ni, 89.2%id, 0.0%hi, 0.1%si, 0.0%st" & @CRLF & _
"Mem: 123456K total, 1234567k used, 989991k free, 11156793k buffers" & @CRLF & _
"Swap: 456K total, 30897564k used, 785431k free, 23445897k cached" & @CRLF & _
"" & @CRLF & _
"PID User Pr NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND" & @CRLF & _
"24 455 36 63 700 800 900 456 87 35 46" & @CRLF & _
"2 root 80 0 0 0 0 0 0 0 0 0 0 0 0 0 0 thread" & @CRLF & _
"" & @CRLF & _
"crt - 00:00:04 up 200 days, 23:39, 0 users, load average: 0.04, 0.05, 0.02" & @CRLF & _
"Tasks: 300 total, 2 running, 298 sleeping, 0 stopped, 0 zombie" & @CRLF & _
"Cpu(s): 12.0%us, 2.5%sy, 0.0%ni, 89.2%id, 0.0%hi, 0.1%si, 0.0%st" & @CRLF & _
"Mem: 123456K total, 1234567k used, 989991k free, 11156793k buffers" & @CRLF & _
"Swap: 456K total, 30897564k used, 785431k free, 23445897k cached"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")