import re
regex = re.compile(r"(?:^crt|\G(?!\A))(?:(?!^$)\D)*\K[.:\d]+", flags=re.MULTILINE)
test_str = ("crt - 00:00:00 up 200 days, 23:35, 0 users, load average: 0.04, 0.05, 0.02\n"
"Tasks: 300 total, 2 running, 298 sleeping, 0 stopped, 0 zombie\n"
"Cpu(s): 12.0%us, 2.5%sy, 0.0%ni, 89.2%id, 0.0%hi, 0.1%si, 0.0%st\n"
"Mem: 123456K total, 1234567k used, 989991k free, 11156793k buffers\n"
"Swap: 456K total, 30897564k used, 785431k free, 23445897k cached\n\n"
"PID User Pr NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND\n"
"24 455 36 63 700 800 900 456 87 35 46\n"
"2 root 80 0 0 0 0 0 0 0 0 0 0 0 0 0 0 thread\n\n"
"crt - 00:00:04 up 200 days, 23:39, 0 users, load average: 0.04, 0.05, 0.02\n"
"Tasks: 300 total, 2 running, 298 sleeping, 0 stopped, 0 zombie\n"
"Cpu(s): 12.0%us, 2.5%sy, 0.0%ni, 89.2%id, 0.0%hi, 0.1%si, 0.0%st\n"
"Mem: 123456K total, 1234567k used, 989991k free, 11156793k buffers\n"
"Swap: 456K total, 30897564k used, 785431k free, 23445897k cached")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")