use strict;
my $str = 'Device|rReq_PS|wReq_PS|rKB_PS|wKB_PS|avgWaitMillis|avgSvcMillis|bandwUtilPct
loop0|0.00|0.00|0.00|0.00|0.00|0.00|0.00
loop1|0.00|0.00|0.00|0.00|0.00|0.00|0.00
loop2|0.00|0.00|0.00|0.00|0.00|0.00|0.00
loop3|0.00|0.00|0.00|0.00|0.00|0.00|0.00
loop4|0.00|0.00|0.00|0.00|0.00|0.00|0.00
nvme0n1|0.00|14.00|0.00|88.00|0.00|0.00|0.00';
my $regex = qr/^(?P<io_device_name>.*)\|(?P<io_read_req_per_sec>.*)\|(?P<io_write_req_per_sec>.*)\|(?P<io_read_kb_per_sec>.*)\|(?P<io_write_kb_per_sec>.*)\|(?P<io_req_avg_wait_millisec>.*)\|(?P<io_req_avg_service_millisec>.*)\|(?P<io_bandwith_utilization_percent>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}