# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?P<io_device_name>.*)\|(?P<io_read_req_per_sec>.*)\|(?P<io_write_req_per_sec>.*)\|(?P<io_read_kb_per_sec>.*)\|(?P<io_write_kb_per_sec>.*)\|(?P<io_req_avg_wait_millisec>.*)\|(?P<io_req_avg_service_millisec>.*)\|(?P<io_bandwith_utilization_percent>.*)"
test_str = ("Device|rReq_PS|wReq_PS|rKB_PS|wKB_PS|avgWaitMillis|avgSvcMillis|bandwUtilPct\n"
"loop0|0.00|0.00|0.00|0.00|0.00|0.00|0.00\n"
"loop1|0.00|0.00|0.00|0.00|0.00|0.00|0.00\n"
"loop2|0.00|0.00|0.00|0.00|0.00|0.00|0.00\n"
"loop3|0.00|0.00|0.00|0.00|0.00|0.00|0.00\n"
"loop4|0.00|0.00|0.00|0.00|0.00|0.00|0.00\n"
"nvme0n1|0.00|14.00|0.00|88.00|0.00|0.00|0.00")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.