package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\w+\.(?:gif|png|jpe?g)`)
var str = `Match four pictures like this: pic1.jpg, pic2.png, pic3.gif, and pic4.jpeg for example, but not these: document5.pdf and excel7.xls.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}