re = /\w+\.(?:gif|png|jpe?g)/i
str = 'Match four pictures like this: pic1.jpg, pic2.png, pic3.gif, and pic4.jpeg for example, but not these: document5.pdf and excel7.xls.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end