using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(?=\""\:)";
string input = @"{""query"":{""filter"":{""column"":{""productName"":""Some Product"",""price"":29.95},""table"":{""productType"":""GM"",""categoryId"":1}}}}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}