re = /\w+(?=\"\:)/
str = '{"query":{"filter":{"column":{"productName":"Some Product","price":29.95},"table":{"productType":"GM","categoryId":1}}}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end