using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"input..*(?<=name=['|""])([\w]+)['|""]";
string input = @"<form method=""post"" action=""guardar.php"">
<input type=""hidden"" name=""produto1"" value=""teste1"">
<input type=""hidden"" name='produto2' value=""teste2"">
<input name=""produto3"" type=""hidden"" value=""teste3"">
<input type=""hidden"" name='produto4' value=""teste4"">
<input type=""hidden"" name=""produto5"" value=""teste5"">
<input type=""submit"" value=""enviar"">
</form>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}